Verschiedene PHP-Versionen unter Linux nebeneinander

22.06.2011

Zwischen PHP-5.2-Code und -5.3-Code bestehen Inkompatibilitäten, insbesondere wenn die erst mit 5.3 eingeführten Namespaces genutzt werden.

Als ich daher unter Linux verschiedene PHP-Versionen nebeneinander nutzen wollte, fand ich den Artikel Linux Devblog: Running Multiple PHP Versions sehr hilfreich.

Da es beim Kompilieren bei mir zu Unklarheiten kam, welche Abhängigkeiten tatsächlich installiert werden müssen (bei einigen Bibliotheken werden zusätzliche dev-Pakete fällig), empfehle ich auch PHP Configure und Compile Fehler.